Ergebnis 1 bis 5 von 5

Thema: Batchauftrag wird bei Sicherung nicht ausgeführt

  1. #1
    Neuer Benutzer
    Registriert seit
    07.11.2003
    Beiträge
    3

    Böse Batchauftrag wird bei Sicherung nicht ausgeführt

    Hi,

    vielleicht könnt Ihr mir helfen.
    Wir haben eine Active Directory Domain.
    Das ITZ besteht aus einer Win2003 Standard und Enterprise Farm.

    Auf einem Server, ist Mitgliedsserver, gehört zur Gruppe Domaincomputer,
    läuft Veritas 9.1

    Wenn man in einem Auftrag angibt, dass vorher eine Batch Datei ausgeführt werden soll, schlägt es fehl.
    Die Batchdatei wird nicht ausgeführt.

    wir haben folgendes Problem:

    ###

    Befehl vor Auftrag wird gestartet: < \\sql\batch\test.bat >

    Fehler: Vor dem Auftrag auszuführender Befehl < \\sql\batch\test.bat > konnte nicht gestartet werden. Fehler (1314): Dem Client fehlt ein erforderliches Recht.

    Fehler: Auftrag Sichern 0115 abgebrochen.

    ###

    Der Auftrag schlägt auch mit .cmd Dateien fehl.
    Auch absolute Pfade ( C:\batch\test.bat ) funktionieren nicht.

    Es ist aber nicht ersichtlich, ob es wirklich ein Rechteproblem ist.
    Sowohl in den Group Policies vom Active Directory,
    als auch in den lokalen Sicherheitsrichtlinien wurden alle wichtigen Rechte für den Backup user vergeben.

    Der User heisst "backup".
    Dem user "backup" wurden folgende Gruppen zugewiesen:
    Administratoren
    Domain Admins
    Organisations Admins
    Sicherungs Operatoren
    Der User "backup" hat die primäre Gruppe "Organisations Admins".

    In der Batch Datei steht jetzt lediglich:

    ###

    dir > test.bat

    ###

    Die Batch Datei funktioniert, wenn Sie direkt gestartet wird. Auch unter dem User Account "backup".


    In der lokalen Sicherheitsrichtlinie wurde der user "backup" folgenden policies zugewiesen.
    -Anmelden als Dienst
    -Anmelden als Stapelverarbeitungsauftrag
    -Einsetzen als Teil des Betriebssystems
    -Erstellen eines Tokenobjektes
    -Sichern von Dateien und Verzeichnissen
    -Widerherstellen von Dateien und Verzeichnissen

    In der Group policy wurden ebenfalls diese Einstellungen vorgenommen.

    Auf die Verzeichnisse, wo jeweils die Batchdateien lagen, wurden volle Reche erteilt.

    Ich habe mit dem filemon von sysinternals.com geschaut, ob Veritas überhaupt versucht auf die Datei test.bat zuzugreifen.
    Ich habe zumindest keinen EIntrag gefunden, dass dies so ist.
    Und damit auch kein Eintrag, ob ein Zugriff verweigert wurde.


    Auch die Group Policy wurde immer mit gpupdate erzwungen, um sicherzustellen, dass die Änderungen akzeptiert wurden. Und noch ein Problem besteht: Nach einem Neustart des Servers werden drei Dienste von Backup Exec nicht gestartet, obwohl sie auf automatisch stehen: -Backup Exec Device & Media Service -Backup Exec Job Engine -Backup Exec Server Der dritte Dienst ist abhängig vom Device & Media Service und startet sofort, nachdem man den Device & Media Service manuell gestartet hat. Alle Backup Exec Dienste werden unter dem user backup gestartet. Die anderen Backup Dienste von Backup Exec starten.


    Wenn Ihr Ideen habt oder Erfahrung darin,
    würde ich Luftsprünge machen...
    :-)


    Gruß
    Mathias
    Mit freundlichem Gruß
    Mathias Kopyczynski

    JMC Technologieberatung
    http://jmc.net

  2. #2
    Neuer Benutzer
    Registriert seit
    14.11.2003
    Beiträge
    11

    Standard

    Hallo Matthias,

    als erstes solltest du prüfen ob der Backup User auch das Recht hat sich als Dienst anzumelden. Dann solltest due das Ereigniss Protokoll kontrolieren und nachsehen, warum der Dienst nicht startet - Ich verwende leider kein Veritas, daher kann ich dir nichts genaues sagen, aber ich gehe davon aus, das der Job Service für das Ausführen deiner Backups verantwortlich ist.

    Um eine genaue Analyse zumachen, kannst du dich auch als Backup user Anmelden und versuchen die Datei auszuführen. Evtl. kann der User wirklich nciht drauf zurgreifen.

    Viel mehr gedanken würde ich mir aber um die nicht gestarteten Dienste machen, die sollten auf alle Fälle ordentlich ausgeführt werden.

    Ganz generell würde ich dienste auch über das konto "lokales System" ausführen. Den Zugriff auf die Server für eine Sicherung müßte sich in einem vernümpftigen backupprogramm einzeln einstellen lassen (ich gehe davon aus, das es auch bei Veritas möglich ist...)

    mfg
    XeogX

  3. #3
    Quoten-Depp Avatar von BeoWulf
    Registriert seit
    18.06.2003
    Beiträge
    2,805

    Standard

    danke xeogx, hab zwar auch vermutet das es was mit dem service/dienst zu tun hatte, war mir aber nicht sicher.

    thx for your answer from

    BeoWulf
    Wer Rechtschreibfehler findet, der kann se gerne behalten. Ja ich kenn Groß- und Kleinschreibung,so gehts aber einfach schneller :P

  4. #4
    Neuer Benutzer
    Registriert seit
    07.11.2003
    Beiträge
    3

    Frage Habe die lösung

    Hi,

    also es hatte nichts mit Rechten zu tun.
    Der Effekt, dass nach einem Neustart, die Dienste des Backup Exec nicht starteten,
    lies mich darauf schließen,
    dass einiges im Argen war.

    Ich nahm einen testserver und installierte Veritas Backup Exec 9.0.
    Die Umgebung war dieselbe, mit Ausnahme von SAN und Tape Library.
    Batch Dateien gingen, Services starteten normal...


    Ich habe dann Veritas vom Server runtergeschmissen, registry gesäubert und neu drauf geschmissen.

    reine Version 9.0 ohne Updates.
    Und siehe da, alles funktioniert, sogar die automatisierte Ausgabe von Bandlaufwerken nach der Sicherung.



    Ich hatte letzten erneut einen Fall mit einem Server, der auch ein Upgrade zu 9.1 gemacht hat.
    Dort war es noch viel problematischer.
    Nach einem neustart, ließ sich der Server nicht mehr hochfahren.
    Ständig erneute Neustarts.

    kein abgesicherter Modus, keine reparatur konsole half.
    Nur ein abgespecktes Update von Server 2003 half.




    Habe Ende Februar ein technisches Training bei veritas für die Version 9.1...
    Na auf die Antworten zu meinen Fragen bin ich mal gespannt...
    ;-)



    Gruß
    Mathias Kopyczynski

    JMC Technologieberatung GmbH
    jmc.net
    Mit freundlichem Gruß
    Mathias Kopyczynski

    JMC Technologieberatung
    http://jmc.net

  5. #5
    Quoten-Depp Avatar von BeoWulf
    Registriert seit
    18.06.2003
    Beiträge
    2,805

    Standard

    freut mich und danke das du auch geschrieben hast woran es gelegen hat, evtl hat ja mal ein zukünftiger user das selbe problem.

    Beo
    Wer Rechtschreibfehler findet, der kann se gerne behalten. Ja ich kenn Groß- und Kleinschreibung,so gehts aber einfach schneller :P

Ähnliche Themen

  1. Zertifikat wird nicht importiert?
    Von Justus_ch im Forum Windows Vista
    Antworten: 5
    Letzter Beitrag: 25.10.2007, 10:48
  2. Antworten: 9
    Letzter Beitrag: 05.06.2007, 15:28
  3. Richtlinie wird nicht auf die Rechner angewendet
    Von Alex20 im Forum Windows Server
    Antworten: 1
    Letzter Beitrag: 10.10.2005, 15:17
  4. Postfach wird nicht repliziert
    Von s.wiesenbacher im Forum Windows Server
    Antworten: 0
    Letzter Beitrag: 20.08.2005, 11:01
  5. Rechner wird in Domäne nicht angezeigt
    Von poldi112 im Forum Windows Server
    Antworten: 2
    Letzter Beitrag: 27.12.2004, 18:02

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •