Ergebnis 1 bis 3 von 3

Thema: Einstellung des Passive Port Range für MSFTP-Service hat keine Wirkung ??

  1. #1
    Neuer Benutzer
    Registriert seit
    22.06.2006
    Beiträge
    2

    Böse Einstellung des Passive Port Range für MSFTP-Service hat keine Wirkung ??

    Hallo,

    riesen Problem mit dem firewalling eines W2k3 Servers:

    Ich habe genau nach vorgabe des Artikels us der MS KnowledgeBase (KB555022) den Passive Port Range für den MS-FTP-Service eingestellt - Das wohl auch erfolgreich:

    C:\Inetpub\AdminScripts>adsutil.vbs get /MSFTPSVC/PassivePortRange
    Microsoft (R) Windows Script Host Version 5.6
    Copyright (C) Microsoft Corporation 1996-2001. All rights reserved.

    PassivePortRange : (STRING) "5001-6000"

    Dummerweise interessiert sich der FTP_Service in keinster Weise für diese Einstellung und versucht dauernd trotzdem den Port zu benutzen der Ihm gerade passt, was dann in der Firewall natürlich hängen bleibt:

    [11:48:47] 227 Entering Passive Mode (80,82,66,11,23,116).
    [11:48:47] Opening data connection to 80.82.66.11 Port: 6004
    [11:48:47] STOR websrv.exe
    [11:48:59] 425 Can't open data connection.
    [11:48:59] Transfer failed.

    Was bitte soll der Scheiss ?? Hab ich da irgendwas übersehen oder vergessen ? Wo sonst kann ich den PortRange einstellen? das ganze ist ein bisschen prekär, weil das natürlich ausgrechnet ein WebServer für Mass-Virtual-Hosting ist, auf den ja fast keiner via FTP zugreifen will ;-)

    Any Ideas ??

    Gruss
    Andreas

  2. #2
    Neuer Benutzer
    Registriert seit
    23.08.2006
    Beiträge
    7

    Standard RE: Einstellung des Passive Port Range für MSFTP-Service hat keine Wirkung ??

    Hallo

    Schau mal hier nach, ob das ganz überhaupt in der Registry abgelegt ist.

    HKEY LOCAL MACHINE\System\CurrentControlSet\Services\Msftpsvc \Parameters\

    Passivportrange REG_SZ

    Es kann natürlich sein, dass es ein REG_MULTI_SZ sein muss, damit es funktioniert.

    Bei den RPC Ports ist das genau so.

    Hast du den Dienst auch neu gestartet ?

    Gruss
    MCSE2003

  3. #3
    Neuer Benutzer
    Registriert seit
    23.08.2006
    Beiträge
    7

    Standard RE: Einstellung des Passive Port Range für MSFTP-Service hat keine Wirkung ??

    Hallo

    Ich habe noch etwas gefunden

    a) To Enable Direct Metabase Edit
    1. Open the IIS Microsoft Management Console (MMC).
    2. Right-click on the Local Computer node.
    3. Select Properties.
    4. Make sure the Enable Direct Metabase Edit checkbox is checked.


    b) Configure PassivePortRange via ADSUTIL script
    1. Click Start, click Run, type cmd, and then click OK.
    2. Type cd Inetpub\AdminScripts and then press ENTER.
    3. Type the following command from a command prompt.
    adsutil.vbs set /MSFTPSVC/PassivePortRange "5500-5700"
    4. Restart the FTP service.

Ähnliche Themen

  1. Einstellung des Passive Port Range für MSFTP-Service hat keine Wirkung ??
    Von abalg im Forum Firewalling | Security | Netzwerk allg.
    Antworten: 1
    Letzter Beitrag: 22.06.2006, 13:34
  2. Port Weiterleitung
    Von Ghostbear im Forum Firewalling | Security | Netzwerk allg.
    Antworten: 4
    Letzter Beitrag: 06.04.2006, 13:44
  3. Port 80 Sperren
    Von Arma_Geddon im Forum Windows 95 - XP | sonstige
    Antworten: 16
    Letzter Beitrag: 28.07.2005, 09:03
  4. TSWEB - Port & Terminalserver
    Von mirko im Forum Windows Server
    Antworten: 8
    Letzter Beitrag: 22.12.2004, 02:28
  5. Antworten: 1
    Letzter Beitrag: 05.02.2004, 02:19

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •